Apache Tomcat 5.x < 5.5.35 Hash Collision Denial of Service

Medium Nessus Plugin ID 57540

Synopsis

The remote web server is affected by a denial of service vulnerability

Description

According to its self-reported version number, the instance of Apache Tomcat 5.x listening on the remote host is prior to 5.5.35. It is, therefore, affected by a denial of service vulnerability.

Large numbers of crafted form parameters can cause excessive CPU consumption due to hash collisions.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Tomcat 5.5.35 or later. Alternatively, as a workaround, set the 'maxPostSize' configuration variable to the lowest sensible value required to support your hosted applications.

See Also

http://www.nessus.org/u?d97dc97c

http://www.nruns.com/_downloads/advisory28122011.pdf

http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.35

Plugin Details

Severity: Medium

ID: 57540

File Name: tomcat_5_5_35.nasl

Version: 1.15

Type: remote

Family: Web Servers

Published: 2012/01/13

Updated: 2018/08/01

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/01/16

Vulnerability Publication Date: 2011/12/28

Reference Information

CVE: CVE-2011-4858, CVE-2012-0022

BID: 51200, 51447

CERT: 903934