Wireshark 1.6.x < 1.6.5 Multiple Vulnerabilities

High Nessus Plugin ID 57539


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark is 1.6.x before 1.6.5. This version is affected by the following vulnerabilities :

- Errors exist in the parsers for '5views', 'i4b', 'iptrace', 'netmon2' and 'novell' packets that can lead to application crashes. (Issues #6663, 6666, 6667, 6668, 6669, 6670)

- An unspecified error exists in the display processing of certain packets that can lead to a NULL pointer dereference. (Issue #6634)

- A buffer overflow exists in the 'RLC' dissector.
(Issue #6391)


Upgrade to Wireshark version 1.6.5 or later.

See Also






Plugin Details

Severity: High

ID: 57539

File Name: wireshark_1_6_5.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2012/01/13

Modified: 2013/11/27

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/01/10

Vulnerability Publication Date: 2012/01/10

Reference Information

CVE: CVE-2012-0041, CVE-2012-0042, CVE-2012-0043, CVE-2012-0066, CVE-2012-0067, CVE-2012-0068

BID: 51368, 51710

OSVDB: 78256, 78257, 78258, 78656, 78657, 78658