Debian DSA-2381-1 : squid3 - invalid memory deallocation

Medium Nessus Plugin ID 57521

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that the IPv6 support code in Squid does not properly handle certain DNS responses, resulting in deallocation of an invalid pointer and a daemon crash.

The squid package and the version of Squid 3 shipped in lenny lack IPv6 support and are not affected by this issue.

Solution

Upgrade the squid3 packages.

For the stable distribution (squeeze), this problem has been fixed in version 3.1.6-1.2+squeeze2.

See Also

https://packages.debian.org/source/squeeze/squid3

https://www.debian.org/security/2012/dsa-2381

Plugin Details

Severity: Medium

ID: 57521

File Name: debian_DSA-2381.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2012/01/12

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:squid3, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/01/06

Reference Information

CVE: CVE-2011-4096

BID: 50449

DSA: 2381