lighttpd < 1.4.30 base64_decode Function Out-of-Bounds Read Error DoS

Medium Nessus Plugin ID 57410


The remote web server is affected by a denial of service vulnerability.


According to its banner, the version of lighttpd running on the remote host is prior to 1.4.30. It is, therefore, affected by a denial of service vulnerability. The HTTP server allows out-of-bounds values to be decoded during the auth process and later uses these values as offsets. Using negative values as offsets can result in application crashes.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to lighttpd version 1.4.30 or later. Alternatively, apply the vendor-supplied patch or disable mod_auth.

See Also

Plugin Details

Severity: Medium

ID: 57410

File Name: lighttpd_1_4_30.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2011/12/28

Modified: 2018/02/07

Dependencies: 10107

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: www/lighttpd, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/12/18

Vulnerability Publication Date: 2011/11/29

Reference Information

CVE: CVE-2011-4362

BID: 50851

OSVDB: 77366

EDB-ID: 18295