Mandriva Linux Security Advisory : icu (MDVSA-2011:194)

High Nessus Plugin ID 57407


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been discovered and corrected in icu :

A stack-based buffer overflow flaw was found in the way ICU performed variant canonicalization for some locale identifiers. If a specially crafted locale representation was opened in an application linked against ICU, it could cause the application to crash or, possibly, execute arbitrary code with the privileges of the user running the application (CVE-2011-4599).

The updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 57407

File Name: mandriva_MDVSA-2011-194.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2011/12/28

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:icu, p-cpe:/a:mandriva:linux:icu-doc, p-cpe:/a:mandriva:linux:lib64icu-devel, p-cpe:/a:mandriva:linux:lib64icu44, p-cpe:/a:mandriva:linux:lib64icu48, p-cpe:/a:mandriva:linux:libicu-devel, p-cpe:/a:mandriva:linux:libicu44, p-cpe:/a:mandriva:linux:libicu48, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/12/27

Reference Information

CVE: CVE-2011-4599

BID: 51006

MDVSA: 2011:194