PuTTY Password Local Information Disclosure

medium Nessus Plugin ID 57365
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host has an SSH client that is affected by an information disclosure vulnerability.

Description

The remote host has an installation of PuTTY between 0.59 and 0.61, inclusive. Such versions are known to contain an information disclosure issue, where PuTTY neglects to wipe passwords from memory that it no longer requires.

Note that to exploit this vulnerability, a malicious, local process must have permission to access the memory assigned to the PuTTY process.

Solution

Upgrade to PuTTY version 0.62.0.0 or later.

See Also

http://www.nessus.org/u?d29e474b

Plugin Details

Severity: Medium

ID: 57365

File Name: putty_062.nasl

Version: 1.8

Type: local

Agent: windows

Family: Windows

Published: 12/21/2011

Updated: 11/26/2018

Dependencies: putty_installed.nasl

Risk Information

CVSS Score Source: CVE-2011-4607

VPR

Risk Factor: Low

Score: 1.4

CVSS v2

Risk Factor: Low

Base Score: 2.1

Temporal Score: 1.6

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:simon_tatham:putty

Required KB Items: installed_sw/PuTTY, SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 12/8/2011

Vulnerability Publication Date: 12/8/2011

Reference Information

CVE: CVE-2011-4607

BID: 51021