Mandriva Linux Security Advisory : libarchive (MDVSA-2011:190)

Medium Nessus Plugin ID 57332


The remote Mandriva Linux host is missing one or more security updates.


Two heap-based buffer overflow flaws were discovered in libarchive. If a user were tricked into expanding a specially crafted ISO 9660 CD-ROM image or tar archive with an application using libarchive, it could cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application (CVE-2011-1777, CVE-2011-1778).

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 57332

File Name: mandriva_MDVSA-2011-190.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2011/12/19

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:bsdcpio, p-cpe:/a:mandriva:linux:bsdtar, p-cpe:/a:mandriva:linux:lib64archive-devel, p-cpe:/a:mandriva:linux:lib64archive2, p-cpe:/a:mandriva:linux:libarchive-devel, p-cpe:/a:mandriva:linux:libarchive2, cpe:/o:mandriva:linux:2010.1, cpe:/o:mandriva:linux:2011

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/12/18

Reference Information

CVE: CVE-2011-1777, CVE-2011-1778

BID: 47737

MDVSA: 2011:190