Apache Tomcat 6.x < 6.0.35 Multiple Vulnerabilities

High Nessus Plugin ID 57080

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 6.x listening on the remote host is prior to 6.0.35. It is, therefore, affected by multiple vulnerabilities :

- Specially crafted requests are incorrectly processed by Tomcat and can cause the server to allow injection of arbitrary AJP messages. This can lead to authentication bypass and disclosure of sensitive information. (CVE-2011-3190)

- An information disclosure vulnerability exists. Request information is cached in two objects and these objects are not recycled at the same time. Further requests can obtain sensitive information if certain error conditions occur. (CVE-2011-3375)

- Large numbers of crafted form parameters can cause excessive CPU consumption due to hash collisions.
(CVE-2011-4858, CVE-2012-0022)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 6.0.35 or later.

See Also

https://bz.apache.org/bugzilla/show_bug.cgi?id=51698#c2

http://svn.apache.org/viewvc?view=revision&revision=1162959

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.35

http://www.nruns.com/_downloads/advisory28122011.pdf

Plugin Details

Severity: High

ID: 57080

File Name: tomcat_6_0_35.nasl

Version: 1.27

Type: remote

Family: Web Servers

Published: 2011/12/12

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/12/05

Vulnerability Publication Date: 2011/08/20

Reference Information

CVE: CVE-2011-3190, CVE-2011-3375, CVE-2011-4858, CVE-2012-0022

BID: 49353, 51200, 51442, 51447

CERT: 903934