OpenSSL < 0.9.8h Multiple Vulnerabilities

Medium Nessus Plugin ID 56996


The remote web server has multiple SSL-related vulnerabilities.


According to its banner, the remote web server uses a version of OpenSSL older than 0.9.8h. As such, it may be affected by the following vulnerabilities :

- A double-free error exists related to the handling of server name extension data and specially crafted TLS 1.0 'Client Hello' packets. This can cause application crashes. Note that successful exploitation requires that OpenSSL is compiled with the TLS server name extensions.

- A NULL pointer dereference error exists related to anonymous Diffie-Hellman key exchange and TLS handshakes. This can be exploited by omitting the 'Server Key exchange message' from the handshake and can cause application crashes. (CVE-2008-1672)

- On 32-bit builds, an information disclosure vulnerability exists during certain calculations for NIST elliptic curves P-256 or P-384. This error can allow an attacker to recover the private key of the TLS server.

The following are required for exploitation :

- 32-bit build
- Use of elliptic curves P-256 and/or P-384
- Either the use of ECDH family ciphers and/or the use of ECDHE family ciphers without the SSL_OP_SINGLE_ECDH_USE context option


Note that Nessus has not attempted to verify that these issues are actually exploitable or have been patched but instead has relied on the version number found in the Server response header.


Upgrade to OpenSSL 0.9.8h or later or apply the vendor-supplied patches.

See Also

Plugin Details

Severity: Medium

ID: 56996

File Name: openssl_0_9_8h.nasl

Version: $Revision: 1.10 $

Type: remote

Family: Web Servers

Published: 2011/12/02

Modified: 2016/12/07

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/05/28

Vulnerability Publication Date: 2008/05/28

Reference Information

CVE: CVE-2008-0891, CVE-2008-1672, CVE-2011-4354

BID: 29405, 50882

OSVDB: 45660, 45661, 77650

CERT: 520586, 661475

CWE: 189, 287