Firefox 3.6.x < 3.6.24 Multiple Vulnerabilities

High Nessus Plugin ID 56750


The remote Windows host contains a web browser that is potentially affected by multiple vulnerabilities.


The installed version of Firefox 3.6.x is earlier than 3.6.24 and is potentially affected by the following vulnerabilities:

- There is an error within the JSSubScriptLoader that incorrectly unwraps 'XPCNativeWrappers'. By tricking a user into installing a malicious plug-in, an attacker could exploit this issue to execute arbitrary code.

- Certain invalid sequences are not handled properly in 'Shift-JIS' encoding and can allow cross-site scripting attacks. (CVE-2011-3648)

- Profiling JavaScript files with many functions can cause the application to crash. It may be possible to trigger this behavior even when the debugging APIs are not being used. (CVE-2011-3650)


Upgrade to Firefox 3.6.24 or later.

See Also

Plugin Details

Severity: High

ID: 56750

File Name: mozilla_firefox_3624.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2011/11/09

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/11/08

Vulnerability Publication Date: 2011/11/08

Reference Information

CVE: CVE-2011-3647, CVE-2011-3648, CVE-2011-3650

BID: 50589, 50593, 50595

OSVDB: 76947, 76948, 76952