Wireshark 1.4.x < 1.4.10 Multiple Vulnerabilities

Medium Nessus Plugin ID 56689


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark is 1.4.x before 1.4.10. This version is affected by the following vulnerabilities :

- An error exists in the Infiniband dissector that can allow a NULL pointer to be dereferenced when processing certain malformed packets. (CVE-2011-4101)

- A buffer overflow exists in the ERF file reader and can be triggered when processing certain malformed packets.


Upgrade to Wireshark version 1.4.10 or later.

See Also




Plugin Details

Severity: Medium

ID: 56689

File Name: wireshark_1_4_10.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2011/11/02

Modified: 2013/03/21

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/11/01

Vulnerability Publication Date: 2011/11/01

Reference Information

CVE: CVE-2011-4101, CVE-2011-4102

BID: 50481, 50486

OSVDB: 76769, 76770