Novell ZENworks Handheld Management ZfHSrvr.exe Multiple Remote Code Execution Vulnerabilities

Critical Nessus Plugin ID 56684


The remote host is running a service affected by multiple remote code execution vulnerabilities.


The ZENworks Handheld Management Server process (ZfHSrvr.exe) contains multiple unspecified remote code execution vulnerabilities that allow an attacker to run arbitrary code on a victim within the context of the 'ZENworks Handheld Management Server' process.


Apply Novell hotfix TID 7009489.

See Also

Plugin Details

Severity: Critical

ID: 56684

File Name: novell_zenworks_handheld_management_zfhsrv_code_execution.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2011/10/31

Modified: 2015/01/12

Dependencies: 10456, 13855, 50679

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:novell:zenworks_handheld_management:7

Required KB Items: SMB/Registry/Enumerated, SMB/ZENworks/ZfHIPCND/Installed, SMB/ZENworks/ZfHIPCND/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/10/05

Vulnerability Publication Date: 2011/10/05

Reference Information

CVE: CVE-2011-2655, CVE-2011-2656

BID: 50303

OSVDB: 76820, 76821