IBM WebSphere Application Server < 6.1.0.29 Multiple Vulnerabilities

Medium Nessus Plugin ID 56683

Synopsis

The remote application server is affected by multiple vulnerabilities.

Description

IBM WebSphere Application Server 6.1 before Fix Pack 29 appears to be running on the remote host. As such, it is reportedly affected by multiple vulnerabilities :

- A cross-site request forgery vulnerability exists due to insufficient validation of user-supplied input by the administrative console. (PK87176)

- Due to an error in Java Naming and Directory Interface, it may be possible to obtain sensitive information.
(PK91414)

- The administrative console is affected by a cross-site scripting vulnerability. (PK92057)

Solution

If using WebSphere Application Server, apply Fix Pack 29 (6.1.0.29) or later.

Otherwise, if using embedded WebSphere Application Server packaged with Tivoli Directory Server, apply the latest recommended eWAS fix pack.

See Also

http://www-01.ibm.com/support/docview.wss?uid=swg21404665

http://www-01.ibm.com/support/docview.wss?uid=swg27009778

http://www-01.ibm.com/support/docview.wss?uid=swg27007951#61029

Plugin Details

Severity: Medium

ID: 56683

File Name: websphere_6_1_0_29.nasl

Version: 1.7

Type: remote

Family: Web Servers

Published: 2011/10/31

Modified: 2018/08/06

Dependencies: 57034

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/01/18

Vulnerability Publication Date: 2009/11/13

Reference Information

CVE: CVE-2009-2746, CVE-2009-2747, CVE-2009-2748

BID: 37015, 37355

CWE: 352