GLSA-201110-21 : Asterisk: Multiple vulnerabilities

High Nessus Plugin ID 56625


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201110-21 (Asterisk: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers referenced below for details.
Impact :

An unauthenticated remote attacker may execute code with the privileges of the Asterisk process or cause a Denial of Service.
Workaround :

There is no known workaround at this time.


All asterisk 1.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-' All asterisk 1.8.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-'

See Also

Plugin Details

Severity: High

ID: 56625

File Name: gentoo_GLSA-201110-21.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2011/10/25

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/10/24

Reference Information

CVE: CVE-2011-1147, CVE-2011-1174, CVE-2011-1175, CVE-2011-1507, CVE-2011-1599, CVE-2011-2529, CVE-2011-2535, CVE-2011-2536, CVE-2011-2665, CVE-2011-2666, CVE-2011-4063

BID: 46474, 46897, 46898, 47537, 48431, 48485, 50177

OSVDB: 70968, 73257, 73307, 73308, 73309, 73405, 73406, 73433, 73434, 74352, 76784

GLSA: 201110-21