Opera < 11.52 Multiple Vulnerabilities

High Nessus Plugin ID 56585


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Opera installed on the remote Windows host is prior to 11.52. It is, therefore, affected by multiple vulnerabilities :

- An unspecified use-after-free error exists due to improper validation of user-supplied input. A remote attacker can exploit this, via a specially crafted web page, to dereference already freed memory, resulting in a crash of the browser. (CVE-2011-4152)

- An error exists related to the handling of certain font manipulations inside dynamically added or specifically embedded SVG images or SVG content in nested frames. A remote attacker can exploit this to crash the application or execute arbitrary code.
(BID 50044 / Issue #1002)

- Multiple unspecified errors exist that allow an attacker to cause a stack overflow condition, resulting in a browser crash.


Upgrade to Opera 11.52 or later.

See Also





Plugin Details

Severity: High

ID: 56585

File Name: opera_1152.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/10/21

Modified: 2016/05/20

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/10/19

Vulnerability Publication Date: 2011/10/10

Reference Information

CVE: CVE-2011-4152

BID: 50044, 50320

OSVDB: 129573

EDB-ID: 17960, 18006, 18008