CentOS 4 / 5 : kdelibs (CESA-2011:1385)

medium Nessus Plugin ID 56559

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated kdelibs packages for Red Hat Enterprise Linux 4 and 5 and updated kdelibs3 packages for Red Hat Enterprise Linux 6 that fix one security issue are now available.

The Red Hat Security Response Team has rated this update as having moderate security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

The kdelibs and kdelibs3 packages provide libraries for the K Desktop Environment (KDE).

An input sanitization flaw was found in the KSSL (KDE SSL Wrapper) API. An attacker could supply a specially crafted SSL certificate (for example, via a web page) to an application using KSSL, such as the Konqueror web browser, causing misleading information to be presented to the user, possibly tricking them into accepting the certificate as valid. (CVE-2011-3365)

Users should upgrade to these updated packages, which contain a backported patch to correct this issue. The desktop must be restarted (log out, then log back in) for this update to take effect.

Solution

Update the affected kdelibs packages.

See Also

http://www.nessus.org/u?97cff4aa

http://www.nessus.org/u?1baf209c

http://www.nessus.org/u?822945dd

http://www.nessus.org/u?5e27a8cf

Plugin Details

Severity: Medium

ID: 56559

File Name: centos_RHSA-2011-1385.nasl

Version: 1.15

Type: local

Agent: unix

Published: 10/20/2011

Updated: 1/4/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:kdelibs, p-cpe:/a:centos:centos:kdelibs-apidocs, p-cpe:/a:centos:centos:kdelibs-devel, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 11/9/2011

Vulnerability Publication Date: 11/29/2011

Reference Information

CVE: CVE-2011-3365

BID: 49925

RHSA: 2011:1385