Wireshark 1.6.x < 1.6.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 56164

Synopsis

The remote Windows host contains an application that is affected by multiple vulnerabilities.

Description

The installed version of Wireshark is 1.6.x before 1.6.2. This version is affected by the following vulnerabilities :

- An error exists in IKE dissector that can allow denial of service attacks when processing certain malformed packets. (CVE-2011-3266)

- A buffer exception handling vulnerability exists that can allow denial of service attacks when processing certain malformed packets. (Issue #6135)

- It may be possible to make Wireshark execute Lua scripts using a method similar to DLL hijacking. (Issue #6136)

- An error exists in OpenSafety dissector that can allow denial of service attacks when processing certain malformed packets. (Issue #6138)

- An error exists in CSN.1 dissector that can allow denial of service attacks when processing certain malformed packets. (Issue #6139)

Solution

Upgrade to Wireshark version 1.6.2 or later.

See Also

http://www.wireshark.org/security/wnpa-sec-2011-12.html

http://www.wireshark.org/security/wnpa-sec-2011-13.html

http://www.wireshark.org/security/wnpa-sec-2011-14.html

http://www.wireshark.org/security/wnpa-sec-2011-15.html

http://www.wireshark.org/security/wnpa-sec-2011-16.html

http://www.wireshark.org/docs/relnotes/wireshark-1.6.2.html

Plugin Details

Severity: Medium

ID: 56164

File Name: wireshark_1_6_2.nasl

Version: 1.13

Type: local

Agent: windows

Family: Windows

Published: 2011/09/12

Modified: 2018/08/06

Dependencies: 34112

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/09/07

Vulnerability Publication Date: 2011/07/28

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark console.lua Pre-Loading Script Execution)

Reference Information

CVE: CVE-2011-3266, CVE-2011-3360, CVE-2011-3482, CVE-2011-3483, CVE-2011-3484

BID: 49377, 49521, 49522, 49524, 49528

EDB-ID: 18125