Wireshark 1.4.x < 1.4.9 Multiple Vulnerabilities

medium Nessus Plugin ID 56163
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 7.4


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark is 1.4.x before 1.4.9. This version is affected by the following vulnerabilities :

- An error exists in IKE dissector that can allow denial of service attacks when processing certain malformed packets. (CVE-2011-3266)

- A buffer exception handling vulnerability exists that can allow denial of service attacks when processing certain malformed packets. (Issue #6135)

- It may be possible to make Wireshark execute Lua scripts using a method similar to DLL hijacking. (Issue #6136)


Upgrade to Wireshark version 1.4.9 or later.

See Also





Plugin Details

Severity: Medium

ID: 56163

File Name: wireshark_1_4_9.nasl

Version: 1.14

Type: local

Agent: windows

Family: Windows

Published: 9/12/2011

Updated: 11/15/2018

Dependencies: wireshark_installed.nasl

Risk Information

Risk Factor: Medium

VPR Score: 7.4

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/7/2011

Vulnerability Publication Date: 7/28/2011

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark console.lua Pre-Loading Script Execution)

Reference Information

CVE: CVE-2011-3266, CVE-2011-3360

BID: 49377, 49521, 49528