Wireshark 1.4.x < 1.4.9 Multiple Vulnerabilities

Medium Nessus Plugin ID 56163


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark is 1.4.x before 1.4.9. This version is affected by the following vulnerabilities :

- An error exists in IKE dissector that can allow denial of service attacks when processing certain malformed packets. (CVE-2011-3266)

- A buffer exception handling vulnerability exists that can allow denial of service attacks when processing certain malformed packets. (Issue #6135)

- It may be possible to make Wireshark execute Lua scripts using a method similar to DLL hijacking. (Issue #6136)


Upgrade to Wireshark version 1.4.9 or later.

See Also





Plugin Details

Severity: Medium

ID: 56163

File Name: wireshark_1_4_9.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2011/09/12

Modified: 2016/11/29

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/09/07

Vulnerability Publication Date: 2011/07/28

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark console.lua Pre-Loading Script Execution)

Reference Information

CVE: CVE-2011-3266, CVE-2011-3360

BID: 49377, 49521, 49528

OSVDB: 74732, 75347