Pidgin < 2.10.0 Multiple Vulnerabilities

High Nessus Plugin ID 55928


An instant messaging client installed on the remote Windows host has multiple vulnerabilities.


The version of Pidgin installed on the remote host is earlier than 2.10.0. As such, it is potentially affected by the following issues :

- A code execution vulnerability caused by clicking on a file:// URI received in an IM that Pidgin will attempt to execute. This can result in the execution of attacker-controlled code if the file is located on a network share. (CVE-2011-3185)

- A denial of service in the IRC protocol plugin caused by processing a specially crafted nickname when listing the set of users. (CVE-2011-2943)

- A denial of service in the MSN protocol plugin caused by incorrect handling of HTTP 100 responses. This only affects users who have enabled the HTTP connection method, which is disabled by default. (CVE-2011-3184)


Upgrade to Pidgin 2.10.0 or later.

See Also

Plugin Details

Severity: High

ID: 55928

File Name: pidgin_2_10_0.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2011/08/22

Modified: 2011/10/24

Dependencies: 34205

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:pidgin:pidgin

Required KB Items: SMB/Pidgin/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/08/20

Vulnerability Publication Date: 2011/08/20

Reference Information

CVE: CVE-2011-2943, CVE-2011-3184, CVE-2011-3185

BID: 49268

OSVDB: 74825, 74826, 74827