Debian DSA-2294-1 : freetype - missing input sanitising

high Nessus Plugin ID 55852
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that insufficient input sanitising in Freetype's code to parse Type1 could lead to the execution of arbitrary code.

Solution

Upgrade the freetype packages.

For the oldstable distribution (lenny), this problem has been fixed in version 2.3.7-2+lenny6.

For the stable distribution (squeeze), this problem has been fixed in version 2.4.2-2.1+squeeze1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=635871

https://packages.debian.org/source/squeeze/freetype

https://www.debian.org/security/2011/dsa-2294

Plugin Details

Severity: High

ID: 55852

File Name: debian_DSA-2294.nasl

Version: 1.11

Type: local

Agent: unix

Published: 8/16/2011

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:freetype, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 8/14/2011

Reference Information

CVE: CVE-2011-0226

DSA: 2294