Adobe Photoshop CS5 GIF File Memory Corruption (APSB11-22)

High Nessus Plugin ID 55815


The remote Windows host has an application that is affected by a memory corruption vulnerability.


The version of Adobe Photoshop CS5 installed on the remote host includes a filter plug-in, 'Standard MultiPlugin', that has a critical memory corruption vulnerability.

If an attacker could trick a user on the affected system into opening a malicious GIF file using the application, he could leverage the vulnerability to execute arbitrary code remotely on the system subject to the user's privileges. This could result in a system compromise.


Upgrade to Adobe Photoshop CS5 / CS5.1 if necessary, then apply the Photoshop CS5 / CS5.1 Standard MultiPlugin Update.

See Also

Plugin Details

Severity: High

ID: 55815

File Name: adobe_photoshop_apsb11-22.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/08/11

Modified: 2015/01/12

Dependencies: 51188

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:photoshop

Required KB Items: SMB/Adobe_Photoshop/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/08/09

Vulnerability Publication Date: 2011/08/09

Reference Information

CVE: CVE-2011-2131

BID: 49106

OSVDB: 74422

EDB-ID: 17712