Debian DSA-2291-1 : squirrelmail - various vulnerabilities

Medium Nessus Plugin ID 55776

Synopsis

The remote Debian host is missing a security-related update.

Description

Various vulnerabilities have been found in SquirrelMail, a webmail application. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities :

- CVE-2010-4554 SquirrelMail did not prevent page rendering inside a third-party HTML frame, which makes it easier for remote attackers to conduct clickjacking attacks via a crafted website.

- CVE-2010-4555, CVE-2011-2752, CVE-2011-2753 Multiple small bugs in SquirrelMail allowed an attacker to inject malicious script into various pages or alter the contents of user preferences.

- CVE-2011-2023 It was possible to inject arbitrary web script or HTML via a crafted STYLE element in an HTML part of an e-mail message.

Solution

Upgrade the squirrelmail packages.

For the oldstable distribution (lenny), these problems have been fixed in version 1.4.15-4+lenny5.

For the stable distribution (squeeze), these problems have been fixed in version 1.4.21-2.

See Also

https://security-tracker.debian.org/tracker/CVE-2010-4554

https://security-tracker.debian.org/tracker/CVE-2010-4555

https://security-tracker.debian.org/tracker/CVE-2011-2752

https://security-tracker.debian.org/tracker/CVE-2011-2753

https://security-tracker.debian.org/tracker/CVE-2011-2023

https://packages.debian.org/source/squeeze/squirrelmail

https://www.debian.org/security/2011/dsa-2291

Plugin Details

Severity: Medium

ID: 55776

File Name: debian_DSA-2291.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2011/08/09

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:squirrelmail, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/08/08

Reference Information

CVE: CVE-2010-4554, CVE-2010-4555, CVE-2011-2023, CVE-2011-2752, CVE-2011-2753

BID: 48648

DSA: 2291