Debian DSA-2280-1 : libvirt - several vulnerabilities

Medium Nessus Plugin ID 55625

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that libvirt, a library for interfacing with different virtualization systems, is prone to an integer overflow (CVE-2011-2511 ). Additionally, the stable version is prone to a denial of service, because its error reporting is not thread-safe (CVE-2011-1486 ).

Solution

Upgrade the libvirt packages.

For the stable distribution (squeeze), these problems have been fixed in version 0.8.3-5+squeeze2.

For the oldstable distribution (lenny), this problem has been fixed in version 0.4.6-10+lenny2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=633630

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=623222

https://security-tracker.debian.org/tracker/CVE-2011-2511

https://security-tracker.debian.org/tracker/CVE-2011-1486

https://packages.debian.org/source/squeeze/libvirt

https://www.debian.org/security/2011/dsa-2280

Plugin Details

Severity: Medium

ID: 55625

File Name: debian_DSA-2280.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2011/07/20

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libvirt, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/07/19

Reference Information

CVE: CVE-2011-1486, CVE-2011-2511

BID: 47148, 48478

DSA: 2280