VLC Media Player 0.5.0 to 1.1.10 Multiple Buffer Overflows

High Nessus Plugin ID 55608


The remote Windows host contains a media player that can allow code execution.


The version of VLC media player installed on the remote host is between 0.5.0 and 1.1.10. As such, it is reportedly affected by multiple vulnerabilities:

- An integer overflow error exists in the handling of the RealAudio portions of RealMedia files. (VideoLAN-SA-1105)

- An integer underflow error exists in the handling of 'strf' portions of AVI files. (VideoLAN-SA-1106)

Exploiting these vulnerabilities can lead to application crashes and possibly code execution through heap-based buffer overflows.


Upgrade to VLC Media Player version 1.1.11 or later.

See Also



Plugin Details

Severity: High

ID: 55608

File Name: vlc_1_1_11.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2011/07/18

Modified: 2014/11/07

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/07/15

Vulnerability Publication Date: 2011/07/12

Reference Information

CVE: CVE-2011-2587, CVE-2011-2588

BID: 48664

OSVDB: 74056, 74057

Secunia: 45066