LibreOffice < 3.3.3 / 3.4.0 LWP File Handling Overflow (Mac OS X)

High Nessus Plugin ID 55576


The remote Mac OS X host has a program affected by a buffer overflow vulnerability.


The version of LibreOffice installed on the remote Mac OS X host is earlier than 3.3.3 / 3.4.0. As such, it is reportedly affected by a stack buffer overflow in the Lotus Word Pro import filter that arises from its failure to properly handle object ids in '.lwp' documents.

If an attacker can trick a user on the affected system into importing a specially crafted .lwp document into the application, he could leverage this issue to execute arbitrary code subject to the user's privileges.


Upgrade to LibreOffice 3.3.3 / 3.4.0 or later.

See Also

Plugin Details

Severity: High

ID: 55576

File Name: macosx_libreoffice_340.nasl

Version: $Revision: 1.4 $

Type: local

Agent: macosx

Published: 2011/07/13

Modified: 2012/04/05

Dependencies: 55575

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: MacOSX/LibreOffice/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/04/06

Vulnerability Publication Date: 2011/06/16

Reference Information

CVE: CVE-2011-2685

BID: 48387

OSVDB: 73314

CERT: 953183