Fedora 14 : wordpress-3.1.4-1.fc14 (2011-8908)

High Nessus Plugin ID 55557


The remote Fedora host is missing a security update.


Upstream security release. Details at http://wordpress.org/news/2011/06/wordpress-3-1-4/ Fix old FSF address and Summary to make rpmlint happy. Make wp-content directory owned by apache:apache. Correctly Provides/Obsoletes (with versions). Upgrade to the latest upstream version (security fixes and enhancements, BZ 707772). Move wp-content directory to /var/www/wordpress/ (BZ 522897).
Simplify overly detailed files list. Actually, we just don't need gettext.php at all, it is provided by php itself. Just remove the file, don't make a symlink. Revert back to wp-content in /usr/share/wordpress, I am not able to make it work. Not fixing BZ 522897.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected wordpress package.

See Also





Plugin Details

Severity: High

ID: 55557

File Name: fedora_2011-8908.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2011/07/12

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:wordpress, cpe:/o:fedoraproject:fedora:14

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2011/06/30

Reference Information

OSVDB: 72173, 73721, 73722, 73723

FEDORA: 2011-8908