Wireshark < 1.2.18 / 1.4.8 / 1.6.1 Multiple Denial of Service Vulnerabilities

Medium Nessus Plugin ID 55510


The remote host has an application that is affected by multiple denial of service vulnerabilities.


The installed version of Wireshark is earlier than 1.2.18 / 1.4.8 / 1.6.1 and thus is potentially affected by multiple denial of service vulnerabilities:

- An error in the Lucent / Ascend file parser can be exploited by specially crafted packets to cause high CPU usage. (CVE-2011-2597)

- An error in the 'elem_cell_id_list' function of the ANSI MAP dissector can be exploited by a specially crafted MAP packet to cause a denial of service condition. (Issue #6044)


Upgrade to Wireshark version 1.2.18 / 1.4.8 / 1.6.1 or later.

See Also




Plugin Details

Severity: Medium

ID: 55510

File Name: wireshark_1_2_18.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2011/07/05

Modified: 2016/05/06

Dependencies: 34112

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/06/29

Vulnerability Publication Date: 2011/05/31

Reference Information

CVE: CVE-2011-2597, CVE-2011-2698

BID: 48150, 48506, 49071

OSVDB: 73687, 74731

Secunia: 45086