Debian DSA-2267-1 : perl - restriction bypass

High Nessus Plugin ID 55487

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that Perl's Safe module - a module to compile and execute code in restricted compartments - could be bypassed.

Please note that this update is known to break Petal, an XML-based templating engine (shipped with Debian 6.0/Squeeze in the package libpetal-perl, see bug #582805 for details). A fix is not yet available. If you use Petal, you might consider to put the previous Perl packages on hold.

Solution

Upgrade the perl packages.

For the oldstable distribution (lenny), this problem has been fixed in version 5.10.0-19lenny5.

For the stable distribution (squeeze), this problem has been fixed in version 5.10.1-17squeeze2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631529

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582805

https://packages.debian.org/source/squeeze/perl

https://www.debian.org/security/2011/dsa-2267

Plugin Details

Severity: High

ID: 55487

File Name: debian_DSA-2267.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2011/07/05

Updated: 2018/11/28

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:perl, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/07/01

Reference Information

CVE: CVE-2010-1447

BID: 40305

DSA: 2267