Google Chrome < 12.0.742.112 Multiple Vulnerabilities

High Nessus Plugin ID 55460


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 12.0.742.112. As such, it is affected by the following vulnerabilities :

- An out-of-bounds read in NPAPI string handling exists.
(Issue #77493)

- A use-after-free issue exists in SVG font handling.
(Issue #84355)

- A memory corruption issue exists in CSS parsing.
(Issue #85003)

- Multiple lifetime and re-entrancy issues exist in the HTML parser. (Issue #85102)

- A bad bounds check exists in v8. (Issue #85177)

- A use-after-free issue exists with the SVG use element.
(Issue #85211)

- A use-after-free issue exists in text selection.
(Issue #85418)


Upgrade to Google Chrome 12.0.742.112 or later.

See Also

Plugin Details

Severity: High

ID: 55460

File Name: google_chrome_12_0_742_112.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/06/29

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/06/28

Vulnerability Publication Date: 2011/06/28

Reference Information

CVE: CVE-2011-2345, CVE-2011-2346, CVE-2011-2347, CVE-2011-2348, CVE-2011-2349, CVE-2011-2350, CVE-2011-2351

BID: 48479

OSVDB: 73504, 73506, 73507, 73508, 73509, 73510, 73511