Foxit Reader < 4.0.0.0619 FreeType Engine RCE

high Nessus Plugin ID 55422
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A PDF viewer installed on the remote host is affected by a remote code execution vulnerability.

Description

The version of Foxit Reader installed on the remote Windows host is prior to 4.0.0.0619. It is, therefore, affected by a remote code execution vulnerability in the FreeType engine due to an integer overflow condition in the Type 1 font decoder. An attacker can exploit this, by tricking a user into opening a crafted PDF file, to cause a denial of service or to execute arbitrary code with the user's privileges.

Solution

Upgrade to Foxit Reader version 4.0.0.0619 or later.

See Also

https://docs.microsoft.com/en-us/security-updates/VulnerabilityResearchAdvisories/2011/msvr11-005

https://www.foxitsoftware.com/support/security-bulletins.php

https://www.foxitsoftware.com/company/press.php?id=191

Plugin Details

Severity: High

ID: 55422

File Name: foxit_reader_4_0_0_0619.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 6/24/2011

Updated: 11/15/2018

Dependencies: foxit_reader_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: installed_sw/Foxit Reader

Exploit Ease: No known exploits are available

Patch Publication Date: 6/29/2010

Vulnerability Publication Date: 6/21/2010

Reference Information

CVE: CVE-2011-1908

BID: 48359

MSVR: MSVR11-005