Firefox < 5.0 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 55419


The remote Mac OS X host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 5.0 and thus, is potentially affected by the following security issues :

- Multiple memory safety issues can lead to application crashes and possibly remote code execution.
(CVE-2011-2374, CVE-2011-2375)

- A use-after-free issue when viewing XUL documents with scripts disabled could lead to code execution.

- A memory corruption issue due to multipart / x-mixed-replace images could lead to memory corruption.

- When a JavaScript Array object has its length set to an extremely large value, the iteration of array elements that occurs when its reduceRight method is called could result in code execution due to an invalid index value being used. (CVE-2011-2371)

- It is possible for an image from a different domain to be loaded into a WebGL texture which could be used to steal image data from a different site. (CVE-2011-2366, CVE-2011-2598)

- An out-of-bounds read issue and an invalid write issue could cause the application to crash. (CVE-2011-2367, CVE-2011-2368)

- HTML-encoded entities are improperly decoded when displayed inside SVG elements which could lead to cross-site scripting attacks. (CVE-2011-2369)

- It is possible for a non-whitelisted site to trigger an install dialog for add-ons and themes. (CVE-2011-2370)


Upgrade to Firefox 5.0 or later.

See Also

Plugin Details

Severity: High

ID: 55419

File Name: macosx_firefox_5_0.nasl

Version: $Revision: 1.12 $

Type: local

Agent: macosx

Published: 2011/06/24

Modified: 2017/06/06

Dependencies: 55417

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/06/21

Vulnerability Publication Date: 2011/06/21

Exploitable With


Metasploit (Mozilla Firefox Array.reduceRight() Integer Overflow)

Reference Information

CVE: CVE-2011-2366, CVE-2011-2367, CVE-2011-2368, CVE-2011-2369, CVE-2011-2370, CVE-2011-2371, CVE-2011-2373, CVE-2011-2374, CVE-2011-2375, CVE-2011-2377, CVE-2011-2598

BID: 48319, 48361, 48365, 48365, 48369, 48371, 48372, 48373, 48375, 48379, 48380

OSVDB: 73101, 73177, 73178, 73182, 73183, 73184, 73189, 73190, 73191, 73192, 73193

Secunia: 44982