Asterisk SIP Channel Driver Denial of Service (AST-2011-007)

low Nessus Plugin ID 54971
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A telephony application running on the remote host is affected by a denial of service vulnerability.

Description

According to the version in its SIP banner, the version of Asterisk running on the remote host is 1.8.x prior to 1.8.4.2. It, therefore, could be affected by a denial of service vulnerability.

If a remote attacker initiates a SIP call and the recipient picks up, the remote user can reply with a malformed Contact header that will cause Asterisk to crash.

Solution

Upgrade to Asterisk 1.8.4.2 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2011-007.html

https://seclists.org/bugtraq/2011/Jun/27

Plugin Details

Severity: Low

ID: 54971

File Name: asterisk_ast_2011_007.nasl

Version: 1.16

Type: remote

Published: 6/5/2011

Updated: 11/15/2018

Dependencies: asterisk_detection.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, asterisk/sip_detected

Exploit Ease: No known exploits are available

Patch Publication Date: 6/2/2011

Vulnerability Publication Date: 6/2/2011

Reference Information

CVE: CVE-2011-2216

BID: 48096

Secunia: 44828