Wireshark < 1.2.17 / 1.4.7 Multiple DoS Vulnerabilities

Medium Nessus Plugin ID 54942

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.2


The remote Windows host contains an application that is affected by multiple denial of service vulnerabilities.


The installed version of Wireshark is 1.2.x less than 1.2.17 or 1.4.x less than 1.4.7. As such, it is affected by the following vulnerabilities :
- An error exists in DICOM dissector that can allow denial of service attacks when processing certain malformed packets. (Issue #5876)

- An error exists in the handling of corrupted snoop files that can cause application crashes. (Issue #5912)

- An error exists in the handling of compressed capture data that can cause application crashes. (Issue #5908)

- An error exists in the handling of 'Visual Networks' files that can cause application crashes. (Issue #5934)

- An error exists in the 'desegment_tcp()' function in the file 'epan/dissectors/packet-tcp.c' that can allow a NULL pointer to be dereferenced when handling certain TCP segments. (Issue #5837)

- An error exists in the handling of corrupted 'Diameter' dictionary files that can cause application crashes. (CVE-2011-1958)


Upgrade to Wireshark version 1.2.17 / 1.4.7 or later.

See Also










Plugin Details

Severity: Medium

ID: 54942

File Name: wireshark_1_4_7.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 2011/06/02

Updated: 2018/11/15

Dependencies: 34112

Risk Information

Risk Factor: Medium

VPR Score: 4.2

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/05/31

Vulnerability Publication Date: 2011/05/31

Reference Information

CVE: CVE-2011-1956, CVE-2011-1957, CVE-2011-1958, CVE-2011-1959, CVE-2011-2174, CVE-2011-2175

BID: 48066

Secunia: 44449