Fedora 15 : systemtap-1.4-9.fc15 (2011-7314)

Low Nessus Plugin ID 54837


The remote Fedora host is missing a security update.


Two divide-by-zero flaws were found in the way systemtap interpreted certain corrupted DWARF expressions. A privileged user able to execute arbitrary systemtap scripts could be tricked into triggering this flaw to crash the target machine. An unprivileged user (in the stapusr group) may be able to trigger this flaw to crash the target machine, only if unprivileged mode was enabled by the system administrator.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected systemtap package.

See Also




Plugin Details

Severity: Low

ID: 54837

File Name: fedora_2011-7314.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2011/05/27

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.2

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:systemtap, cpe:/o:fedoraproject:fedora:15

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2011/05/20

Reference Information

CVE: CVE-2011-1769, CVE-2011-1781

FEDORA: 2011-7314