SynopsisThe remote mail server is potentially affected by a memory corruption vulnerability.
DescriptionAccording to its banner, the version of the Postfix mail server listening on this port is earlier than 2.5.13, 2.6.19, 2.7.4, or 2.8.3. Such versions may be vulnerable to a memory corruption attack if they have Cyrus SASL enabled and are allowing authentication methods other than ANONYMOUS, LOGIN, and PLAIN. Code execution as the unprivileged postfix user may also be possible.
Note that Nessus did not test whether the remote server was using Cyrus specifically, as opposed to another SASL library such as Dovecot.
SolutionUpgrade to Postfix 2.5.13 / 2.6.19 / 2.7.4 / 2.8.3 or later.