Postfix Cyrus SASL Authentication Context Data Reuse Memory Corruption

medium Nessus Plugin ID 54583
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote mail server is potentially affected by a memory corruption vulnerability.

Description

According to its banner, the version of the Postfix mail server listening on this port is earlier than 2.5.13, 2.6.19, 2.7.4, or 2.8.3. Such versions may be vulnerable to a memory corruption attack if they have Cyrus SASL enabled and are allowing authentication methods other than ANONYMOUS, LOGIN, and PLAIN. Code execution as the unprivileged postfix user may also be possible.

Note that Nessus did not test whether the remote server was using Cyrus specifically, as opposed to another SASL library such as Dovecot.

Solution

Upgrade to Postfix 2.5.13 / 2.6.19 / 2.7.4 / 2.8.3 or later.

See Also

http://www.postfix.org/CVE-2011-1720.html

https://seclists.org/bugtraq/2011/May/64

Plugin Details

Severity: Medium

ID: 54583

File Name: postfix_memory_corruption.nasl

Version: 1.7

Type: remote

Published: 5/19/2011

Updated: 11/15/2018

Dependencies: smtp_authentication.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:postfix:postfix:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, SMTP/postfix

Exploit Ease: No known exploits are available

Patch Publication Date: 5/9/2011

Vulnerability Publication Date: 5/9/2011

Reference Information

CVE: CVE-2011-1720

BID: 47778

CERT: 727230

Secunia: 44500