Mozilla Thunderbird 3.1 < 3.1.10 Multiple Vulnerabilities

High Nessus Plugin ID 53596

Synopsis

The remote Windows host contains a mail client that is affected by multiple vulnerabilities.

Description

The installed version of Thunderbird 3.1 is earlier than 3.1.10. Such versions are potentially affected by the following security issues :

- An error in the resource protocol can allow directory traversal. (CVE-2011-0071)

- Multiple memory safety issues can lead to application crashes and possibly remote code execution.
(CVE-2011-0069, CVE-2011-0070, CVE-2011-0072, CVE-2011-0074, CVE-2011-0075, CVE-2011-0077, CVE-2011-0078, CVE-2011-0080, CVE-2011-0081)

Solution

Upgrade to Thunderbird 3.1.10 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2011-12/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-16/

http://www.nessus.org/u?353363cb

Plugin Details

Severity: High

ID: 53596

File Name: mozilla_thunderbird_3110.nasl

Version: 1.11

Type: local

Agent: windows

Family: Windows

Published: 2011/04/29

Updated: 2018/07/16

Dependencies: 20862

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: Mozilla/Thunderbird/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/04/28

Vulnerability Publication Date: 2011/04/28

Reference Information

CVE: CVE-2011-0069, CVE-2011-0070, CVE-2011-0071, CVE-2011-0072, CVE-2011-0074, CVE-2011-0075, CVE-2011-0077, CVE-2011-0078, CVE-2011-0080, CVE-2011-0081

BID: 47641, 47646, 47647, 47648, 47651, 47653, 47654, 47655, 47656, 47657, 47666

Secunia: 44407