Firefox 4.0 < 4.0.1 Multiple Vulnerabilities

High Nessus Plugin ID 53595


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox 4.0 is earlier than 4.0.1. As such, it is potentially affected by the following security issues :

- A buffer overflow exists in the WebGLES library.
Additionally, the Windows version was not compiled with ASLR enabled. (CVE-2011-0068)

- Multiple memory safety issues can lead to application crashes and possibly remote code execution.
(CVE-2011-0069, CVE-2011-0070, CVE-2011-0079, CVE-2011-0081)

- An information disclosure vulnerability exists in the 'xsltGenerateIdFunction' function in the included libxslt library. (CVE-2011-1202)


Upgrade to Firefox 4.0.1 or later.

See Also

Plugin Details

Severity: High

ID: 53595

File Name: mozilla_firefox_401.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2011/04/29

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/28

Vulnerability Publication Date: 2011/04/28

Exploitable With

Metasploit (Mozilla Firefox "nsTreeRange" Dangling Pointer Vulnerability)

Reference Information

CVE: CVE-2011-0068, CVE-2011-0069, CVE-2011-0070, CVE-2011-0079, CVE-2011-0081, CVE-2011-1202

BID: 47641, 47646, 47648, 47651, 47653, 47654, 47655, 47656, 47657, 47659, 47661, 47662, 47663, 47667, 47668

OSVDB: 72074, 72075, 72076, 72077, 72094, 73801

Secunia: 44406