Mandriva Linux Security Advisory : libtiff (MDVSA-2011:078)

Medium Nessus Plugin ID 53542


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in libtiff :

The libtiff OJPEG decoder contains a heap buffer overflow when decoding certain malformed data (CVE-2009-5022).

The updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 53542

File Name: mandriva_MDVSA-2011-078.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2011/04/25

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64tiff-devel, p-cpe:/a:mandriva:linux:lib64tiff-static-devel, p-cpe:/a:mandriva:linux:lib64tiff3, p-cpe:/a:mandriva:linux:libtiff-devel, p-cpe:/a:mandriva:linux:libtiff-progs, p-cpe:/a:mandriva:linux:libtiff-static-devel, p-cpe:/a:mandriva:linux:libtiff3, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/04/23

Reference Information

CVE: CVE-2009-5022

BID: 47338

OSVDB: 72260

MDVSA: 2011:078