Safari < 5.0.5 Multiple Vulnerabilities

High Nessus Plugin ID 53411


The remote host contains a web browser that is affected by several vulnerabilities.


The version of Safari installed on the remote Windows host is earlier than 5.0.5. It therefore is potentially affected by several issues :

- An integer overflow issue in the handling of nodesets could lead to a crash or arbitrary code execution.

- A use-after-free issue in the handling of text nodes could lead to a crash or arbitrary code execution.


Upgrade to Safari 5.0.5 or later.

See Also

Plugin Details

Severity: High

ID: 53411

File Name: safari_5_0_5.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/04/14

Modified: 2013/06/03

Dependencies: 31788

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/14

Vulnerability Publication Date: 2011/03/11

Reference Information

CVE: CVE-2011-1290, CVE-2011-1344

BID: 46822, 46849

OSVDB: 71182, 72690