Mac OS X : Apple Safari < 5.0.5

high Nessus Plugin ID 53410
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by several vulnerabilities.

Description

The version of Apple Safari installed on the remote Mac OS X host is earlier than 5.0.5. As such, it is potentially affected by several issues :

- An integer overflow issue in the handling of nodesets could lead to a crash or arbitrary code execution.
(CVE-2011-1290)

- A use-after-free issue in the handling of text nodes could lead to a crash or arbitrary code execution.
(CVE-2011-1344)

Solution

Upgrade to Apple Safari 5.0.5 or later.

See Also

http://support.apple.com/kb/HT4596

http://lists.apple.com/archives/security-announce/2011/Apr/msg00002.html

Plugin Details

Severity: High

ID: 53410

File Name: macosx_Safari5_0_5.nasl

Version: 1.10

Type: local

Agent: macosx

Published: 4/14/2011

Updated: 7/14/2018

Dependencies: macosx_Safari31.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/uname, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 4/14/2011

Vulnerability Publication Date: 3/9/2011

Reference Information

CVE: CVE-2011-1290, CVE-2011-1344

BID: 46822, 46849