MS11-028: Vulnerability in .NET Framework Could Allow Remote Code Execution (2484015)

High Nessus Plugin ID 53385

Synopsis

The version of the .NET Framework installed on the remote host allows arbitrary code execution.

Description

The x86 JIT compiler included with the version of the .NET Framework installed on the remote host incorrectly compiles certain types of function calls.

An attacker may be able to leverage this vulnerability to run arbitrary code on the affected system under either of the following scenarios :

- Tricking a user on the affected host into viewing a specially crafted web page using a web browser that can run XAML Browser Applications (XBAPs).

- Uploading a malicious ASP.NET application to be hosted on the affected host.

- Bypassing Code Access Security (CAS) restrictions in a Windows .NET application.

Solution

Microsoft has released a set of patches for the .NET Framework on Windows XP, 2003, Vista, 2008, 7, and 2008 R2.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2011/ms11-028

Plugin Details

Severity: High

ID: 53385

File Name: smb_nt_ms11-028.nasl

Version: 1.19

Type: local

Agent: windows

Published: 2011/04/13

Updated: 2018/11/15

Dependencies: 13855, 57033

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:.net_framework

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/04/12

Vulnerability Publication Date: 2011/04/12

Reference Information

CVE: CVE-2010-3958

BID: 47223

MSFT: MS11-028

MSKB: 2446704, 2446708, 2446709, 2446710, 2449741, 2449742