MS11-022: Vulnerabilities in Microsoft PowerPoint Could Allow Remote Code Execution (2489283)

High Nessus Plugin ID 53379


Arbitrary code can be executed on the remote host through Microsoft PowerPoint.


The remote Windows host has a version of Microsoft PowerPoint that is affected by multiple code execution vulnerabilities. A remote attacker could exploit this by tricking a user into viewing a maliciously crafted PowerPoint file.


Microsoft has released a set of patches for PowerPoint 2002, 2003, 2007, 2010, PowerPoint Viewer 2007 and 2010, Office Compatibility Pack, and Office Web Apps.

See Also

Plugin Details

Severity: High

ID: 53379

File Name: smb_nt_ms11-022.nasl

Version: $Revision: 1.23 $

Type: local

Agent: windows

Published: 2011/04/13

Modified: 2017/07/26

Dependencies: 11336, 27524, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:microsoft:office, cpe:/a:microsoft:office_compatibility_pack, cpe:/a:microsoft:powerpoint, cpe:/a:microsoft:powerpoint_viewer

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/12

Vulnerability Publication Date: 2011/02/07

Exploitable With

Core Impact

Reference Information

CVE: CVE-2011-0655, CVE-2011-0656, CVE-2011-0976

BID: 46228, 47251, 47252

OSVDB: 71769, 71770, 71771

IAVA: 2011-A-0047

MSFT: MS11-022

MSKB: 2464588, 2464594, 2464617, 2464623, 2464635, 2519975, 2519984, 2520047