MS11-021: Vulnerabilities in Microsoft Excel Could Allow Remote Code Execution (2489279)

High Nessus Plugin ID 53378


Arbitrary code can be executed on the remote host through Microsoft Excel.


The remote Windows host is running a version of Microsoft Excel or Excel Viewer that is affected by several vulnerabilities.

If an attacker can trick a user on the affected host into opening a specially crafted Excel file, they could leverage this issue to execute arbitrary code subject to the user's privileges.


Microsoft has released a set of patches for Office XP, 2003, 2007, 2010, Excel Viewer, and Office Compatability Pack.

See Also

Plugin Details

Severity: High

ID: 53378

File Name: smb_nt_ms11-021.nasl

Version: $Revision: 1.25 $

Type: local

Agent: windows

Published: 2011/04/13

Modified: 2017/07/26

Dependencies: 57033, 11336, 27524, 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

Vulnerability Information

CPE: cpe:/a:microsoft:office, cpe:/a:microsoft:excel, cpe:/a:microsoft:excel_viewer, cpe:/a:microsoft:office_compatibility_pack

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/12

Vulnerability Publication Date: 2011/02/07

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (MS11-021 Microsoft Office 2007 Excel .xlb Buffer Overflow)

Reference Information

CVE: CVE-2011-0097, CVE-2011-0098, CVE-2011-0101, CVE-2011-0103, CVE-2011-0104, CVE-2011-0105, CVE-2011-0978, CVE-2011-0979, CVE-2011-0980

BID: 46225, 46226, 46229, 47201, 47235, 47243, 47244, 47245, 47256

OSVDB: 70811, 70812, 70904, 71758, 71759, 71760, 71761, 71765, 71766

EDB-ID: 18067, 18087

MSFT: MS11-021

MSKB: 2464583, 2466146, 2466156, 2466158, 2466169, 2502786