VLC Media Player < 1.1.8 Multiple Buffer Overflows

High Nessus Plugin ID 52976


The remote Windows host contains a media player that is affected by multiple buffer overflow vulnerabilities.


The version of VLC media player installed on the remote host is earlier than 1.1.8. Such versions are reportedly affected by buffer overflow vulnerabilities when handling specially crafted AMV and NSV files, which could result in arbitrary code execution.


Upgrade to VLC Media Player version 1.1.8 or later.

See Also



Plugin Details

Severity: High

ID: 52976

File Name: vlc_1_1_8.nasl

Version: $Revision: 1.11 $

Type: local

Family: Windows

Published: 2011/03/25

Modified: 2016/11/29

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/23

Vulnerability Publication Date: 2011/03/23

Reference Information

CVE: CVE-2010-3275, CVE-2010-3276

BID: 47012

OSVDB: 71277, 71278