Adobe AIR < 2.6 Unspecified Memory Corruption (APSB11-05)

High Nessus Plugin ID 52755


The remote Windows host contains a version of Adobe AIR that is affected by a memory corruption vulnerability.


The remote Windows host contains a version of Adobe AIR earlier than 2.6. Such versions are affected by a memory corruption vulnerability that could allow arbitrary code execution on the remote system or trigger a denial of service condition.


Upgrade to Adobe AIR 2.6 or later.

See Also

Plugin Details

Severity: High

ID: 52755

File Name: adobe_air_apsb11-05.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2011/03/22

Modified: 2016/11/11

Dependencies: 32504

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version, SMB/Adobe_AIR/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/21

Vulnerability Publication Date: 2011/03/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player AVM Bytecode Verification Vulnerability)

Reference Information

CVE: CVE-2011-0609

BID: 46860

OSVDB: 71254

CERT: 192052

EDB-ID: 17027

Secunia: 43751