Asterisk Multiple Denial of Service Vulnerabilities (AST-2011-003 / AST-2011-004)

medium Nessus Plugin ID 52714
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A telephony application running on the remote host is affected by multiple denial of service vulnerabilities.

Description

According to the version in its SIP banner, the version of Asterisk running on the remote host may be affected by multiple denial of service vulnerabilities :

- A resource exhaustion issue exists in the Asterisk manager interface.

- A NULL pointer dereference issue exists in the TCP/TLS server.

Solution

Upgrade to Asterisk 1.6.1.24 / 1.6.2.17.2 / 1.8.3.2 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2011-003.html

http://downloads.asterisk.org/pub/security/AST-2011-004.html

http://www.nessus.org/u?3ecf62e4

Plugin Details

Severity: Medium

ID: 52714

File Name: asterisk_ast_2011_003.nasl

Version: 1.18

Type: remote

Published: 3/18/2011

Updated: 6/27/2018

Dependencies: asterisk_detection.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/17/2011

Vulnerability Publication Date: 3/16/2011

Reference Information

CVE: CVE-2011-1174, CVE-2011-1175

BID: 46897, 46898

Secunia: 43722