Adobe Reader 9.x / 10.x Unspecified Memory Corruption (APSB11-06)

High Nessus Plugin ID 52672


The version of Adobe Reader on the remote Windows host is affected by a memory corruption vulnerability.


The remote Windows host contains a version of Adobe Reader 9.x < 9.4.3 or 10.x < 10.1. Such versions are affected by an unspecified memory corruption vulnerability in authplay.dll.

A remote attacker could exploit this by tricking a user into viewing maliciously crafted SWF content, resulting in arbitrary code execution.

This bug is currently being exploited in the wild.


Upgrade to Adobe Reader 9.4.2 / 10.1 or later.

See Also

Plugin Details

Severity: High

ID: 52672

File Name: adobe_reader_apsa11-01.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2011/03/15

Modified: 2016/11/11

Dependencies: 20836

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/21

Vulnerability Publication Date: 2011/03/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player AVM Bytecode Verification Vulnerability)

Reference Information

CVE: CVE-2011-0609

BID: 46860

OSVDB: 71254

CERT: 192052

EDB-ID: 17027