Adobe Acrobat 9.x / 10.x Unspecified Memory Corruption (APSB11-06)

High Nessus Plugin ID 52671


The version of Adobe Acrobat on the remote Windows host is affected by a memory corruption vulnerability.


The remote Windows host contains a version of Adobe Acrobat 9.x < 9.4.3 or 10.x < 10.0.2. Such versions are affected by an unspecified memory corruption vulnerability in authplay.dll.

A remote attacker could exploit this by tricking a user into viewing maliciously crafted SWF content, resulting in arbitrary code execution.

This bug is currently being exploited in the wild.


Upgrade to Adobe Acrobat 9.4.3 / 10.0.2 or later.

See Also

Plugin Details

Severity: High

ID: 52671

File Name: adobe_acrobat_apsa11-01.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2011/03/15

Modified: 2016/11/11

Dependencies: 40797

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat

Required KB Items: SMB/Acrobat/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/21

Vulnerability Publication Date: 2011/03/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player AVM Bytecode Verification Vulnerability)

Reference Information

CVE: CVE-2011-0609

BID: 46860

OSVDB: 71254

CERT: 192052

EDB-ID: 17027