Google Chrome < 10.0.648.133 Code Execution

High Nessus Plugin ID 52657


The remote host contains a web browser that is affected by a code execution vulnerability.


The version of Google Chrome installed on the remote host is earlier than 10.0.648.133. Such versions are reportedly affected by a memory corruption vulnerability in style handling.

By tricking a user into opening a specially crafted web page, a remote unauthenticated attacker could execute arbitrary script code on the host subject to the privileges of the user running the affected application.


Upgrade to Google Chrome 10.0.648.133 or later.

See Also

Plugin Details

Severity: High

ID: 52657

File Name: google_chrome_10_0_648_133.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2011/03/14

Modified: 2013/11/13

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/03/14

Vulnerability Publication Date: 2011/03/10

Reference Information

CVE: CVE-2011-1290

BID: 46849

OSVDB: 71182

Secunia: 43748