Request Tracker 3.x < 3.8.9 Security Bypass and Information Disclosure

medium Nessus Plugin ID 52455
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running a Perl application that is affected by security bypass and information disclosure vulnerabilities.

Description

According to its self-reported version number, the Best Practical Solutions Request Tracker (RT) running on the remote web server is a version prior to 3.8.9. It is, therefore, potentially affected by the following vulnerabilities :

- If an individual with a valid account logs out of Request Tracker but does not close the browser, an attacker with access to that browser can use the 'back' button to access the previous user's account page.
(CVE-2011-1007)

- An information disclosure vulnerability affects the application when handling the logging of SQL queries during user transition. (CVE-2011-1008)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Request Tracker 3.8.9 or later.

See Also

http://www.nessus.org/u?c1d8bf43

http://www.nessus.org/u?1f132438

http://www.nessus.org/u?4bb973f9

Plugin Details

Severity: Medium

ID: 52455

File Name: rt_389.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2/25/2011

Updated: 1/19/2021

Dependencies: rt_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:bestpractical:rt

Required KB Items: installed_sw/RT, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 2/16/2011

Vulnerability Publication Date: 2/16/2011

Reference Information

CVE: CVE-2011-1007, CVE-2011-1008

BID: 46493

Secunia: 43438